Language:
SEARCH
  • Recent Posts

  • Categories

  • Archives

Microsoft to use more secure encryption

Microsoft recently announced that they will no longer use TLS 1.0 and 1.1 in Office 365. They are moving all online services to Transport Layer Security (TLS) 1.2+ to provide best-in-class encryption, and to ensure the service is more secure by default. 

“We temporarily halted deprecation enforcement of TLS 1.0 and 1.1 for commercial customers due to Covid-19, but as supply chains have adjusted and certain countries open back up, we are resetting the TLS enforcement to start Oct 15, 2020,” Microsoft announced.

Yes, but what does that mean?

In short – Microsoft is switching to more secure security and subsequently older operating systems will no longer work effectively. At Stellenbosch University this means that, once this change takes effect, all connections to Office 365 using the protocols TLS 1.0 and TLS 1.1 will no longer work. This includes:

  • Android 4.3 and earlier versions
  • Firefox version 5.0 and earlier versions
  • Internet Explorer 8-10 on Windows 7 and earlier versions
  • Internet Explorer 10 on Windows Phone 8
  • Safari 6.0.4/OS X10.8.4 and earlier versions

OK, what should I do?

It’s important that you update or replace the software mentioned above and the devices that rely on TLS 1.0 and 1.1 to connect to Office 365.

  • Windows based devices
    Make sure all Windows and Office updates are installed.
    We recommend Windows 10 v1909 and Office 365.
    If you are running Windows and Office versions other than Windows 10 and Office 365, please log a request on the ICT Partner Portal to have your device assessed for possible upgrade to our recommendations.
  • macOS devices
    Make sure all system updates and Office updates are installed.
    We recommend macOS Mojave and higher and Office 365.
    If you are running a macOS device or Office package older than our recommendations, please log a request on the ICT Partner Portal to have your device assessed for possible upgrade to our recommendations.
  • Android and iOS devices
    Need to be updated to latest available update for the device as specified by the manufacturer of the device.
    We recommend that you use the Outlook app to be able to access your emails from the device as this is the most secure application to retrieve your emails.

If your device does not meet the requirements to upgrade its Operating system and Software, we recommend that you purchase a device that is compatible to continue to be able to make use of these services. If you are still unsure of what to do, please log a request on the ICT Partner Portal and we will assist you.

[ARTICLE BY BRADLEY VAN DER VENTER]

Comments are closed.

 

© 2013-2020 Disclaimer: The views and opinions expressed in this page are strictly those of the page author(s) and content contributor(s). The contents of this page have not been reviewed or approved by Stellenbosch University.